Back when I did my Qualcomm modems and transceivers piece, I gained a deeper understanding about the cellular RF engineering side of the handset puzzle. Specifically, how an OEM can enable LTE on some bands and not enable WCDMA on those very same bands. The interesting and relevant takeaway from the whole exploration is that all ports on the transceiver are created equal, and that if an OEM implements LTE on a particular band, that usually means that the device design can inherit support for 3G WCDMA on that same band, given the right power amplifier. I alluded at the end of the article to the fact that if you see an OEM implement band 4 on LTE and not band 4 on WCDMA, it's just a matter of a firmware lock and appropriate certifications to enable it, and what I was alluding directly to was the A1428 iPhone 5.

Today T-Mobile USA formalized their LTE plans and announced that the Samsung Galaxy Note 2 (as predicted), Blackberry Z10, and Sonic 2.0 hotspots would immediately work with their Band 4 LTE which is either 5 or 10 MHz FDD depending on market. In addition the upcoming HTC One and Samsung Galaxy S 4 will support T-Mobile LTE. The operator also launched its LTE network in Baltimore, Houston, Kansas City, Las Vegas, Phoenix, San Jose, Calif., and Washington, D.C. I plan to drive up to Phoenix at some point this week and test the network out there. 

Among all that other news however was news that T-Mobile would finally be carrying the iPhone 5, specifically an updated version of the A1428 hardware model which included Band 4 (AWS) LTE support. This was the variant aimed at AT&T specifically, with both Band 4 and Band 17 LTE included, in addition to a number of other bands as we noted in the iPhone 5 review. As I mentioned earlier, what's interesting about A1428 is that it always had the necessary power amplifiers for AWS WCDMA, but only enabled it on LTE. The hardware could support AWS WCDMA, but that was locked out in firmware — until now. Apple gave a statement to Engadget which confirmed my earlier suspicions – beginning 4/12, Apple will ship a new A1428 with different firmware onboard that enables AWS WCDMA. There won't be any software update for existing A1428 owners, meaning if you bought an iPhone 5 AT&T model, you're not going to be able to get AWS WCDMA on T-Mobile overnight unfortunately, instead new shipping A1428 models will simply have different firmware on them which enables the AWS paths through the transceiver for WCDMA to be enabled. I'm unclear how Apple will choose to differentiate the two identical A1428 hardware models for users or on their own spec lists, either way there will be an old version and new version which differ in this regard. In addition, existing A1428 hardware without AWS WCDMA support will be phased out.

In fact, there's the same FCC-ID for the A1428 with AWS WCDMA enabled, it's still BCG-E2599A. I was surprised to see that Apple has already in fact processed the Class II Permissive Change and added Band 4 (AWS) WCDMA tests as necessary, dated today March 26th 2013. 


From the FCC's A1428 Class 2 Permissive Change Cover Letter

So there we have it, the new A1428 with AWS WCDMA for T-Mobile is identical hardware to the previous A1428 hardware, it's just a matter of enabling those modes in the transceiver for WCDMA. The hardware will also support DC-HSPA+ (42.2 Mbps downlink) on AWS, which means speedy fallback if you detach from LTE and are in a T-Mobile market with two WCDMA carriers.

Source: T-Mobile (LTE and Uncarrier), T-Mobile (iPhone 5), Engadget

POST A COMMENT

31 Comments

View All Comments

  • guju - Thursday, March 28, 2013 - link

    Are you certain...? I was told by an Apple 800# rep via chat that the old A1428 will support HSPA+14.4 and not T-Mobile's faster HSPA+42...

    There still may be confusion. For those with unlocked AT&T iPhone 4 & 4S that want to churn for the cheaper $50/mo unlimited 3G/throttled LTE on T-Mobile, it would be cool to know the full answer. ;)
    Reply
  • Bob Todd - Friday, March 29, 2013 - link

    Yup, and that's how it's been reported everywhere after the dust settled. TMO has single carrier 21Mbps on PCS which the AT&T iPhone 5 can use. Their dual carrier (42Mbps) is all AWS, which is what's not going to work unless they change their mind and offer a firmware update. I imagine some creative folks will come up with a way around the lack of an official baseband update though. Reply
  • Brian Klug - Wednesday, March 27, 2013 - link

    AWS LTE will work on both Old and New A1428 models as soon as Apple begins exposing the TMOUS LTE .ipcc

    -Brian
    Reply
  • IHateMyJob2004 - Tuesday, March 26, 2013 - link

    Where is the front page Blackberrry Z10 review? Reply
  • gonzopancho - Tuesday, March 26, 2013 - link

    in my pants Reply
  • darwinosx - Friday, March 29, 2013 - link

    Yeah there are at least 3 people who care about a Z10 review. Maybe 2. Reply
  • r3loaded - Wednesday, March 27, 2013 - link

    So....is there a way to flash the updated baseband onto existing A1428 iPhones? Reply
  • Guspaz - Wednesday, March 27, 2013 - link

    This is particularly relevant in Canada, where adding support for AWS spectrum will bring the iPhone to at least three carriers, two of them national new-entrants (recently entered the market, WIND and Mobilicity), and one of them a regional incumbent cableco (Videotron). Getting the iPhone to these new carriers has the potential to shake up the market, since the lack of an iPhone has certainly not been helping the new carriers compete against the incumbents. Reply
  • coldpower27 - Wednesday, March 27, 2013 - link

    Yeah, i was wondering if this would enable WIND/Mobilicity to start carrying the iPhone, as that was one of things that has kept me from going to the new cheaper carriers. :S Reply
  • nrm590 - Wednesday, March 27, 2013 - link

    I am curious to know if Apple will update unlocked iPhones with the new firmware.

    I bought an unlocked iPhone 5 in December for use on T-Mobile. I am not that interested in LTE, I just want to maintain a solid 3G connection. T-Mobile's 1900 MHz update has been great, when I have it but it is very annoying to fall back on EDGE.
    Reply

Log in

Don't have an account? Sign up now