Poor Crucial. Although it started its C300 campaign on the right foot, posting some very impressive sequential read speeds thanks to 6Gbps SATA and ONFI 2.0 NAND, things haven't been so smooth lately.

First off, Crucial's timing was unfortunate as it was right around the time we started seeing SandForce make some noise. Secondly, while performance was good, my drive showed some performance and reliability issues within two weeks of receiving it. And third, the firmware update that was supposed to address the problems I had managed to brick some drives

If you bought a C300 there was a chance that your drive would brick itself by just using it. If you used the firmware that fixed the aforementioned problem, then there was a chance the process would brick your drive. 

Crucial just gave me an update on the situation and things appear to be looking up:

Hi Anand, 
 
I wanted to provide you an update on the RealSSD C300 firmware. 
 
As you know, we pulled the v0002 firmware update from the Crucial.com support site on Wednesday, May 5th. We did this to allow our product engineering team time to evaluate reported issues. We have identified a compatibility issue between the update tool and certain motherboards. There are no known issues with the firmware itself. We are revising the update tool to eliminate the known compatibility issues. We plan to begin testing and validating the new update tool early next week (week of May 10th), and we’ll continue to keep you updated. 
 
Although the majority of customers have seen no issues with the update, our goal is to protect customers that may encounter issues.  
 
Please let me know if you have any questions. 
 
The update should go live while I'm out of the country, but it looks like by the end of this month things should finally (hopefully?) be safe for C300 owners. 
POST A COMMENT

23 Comments

View All Comments

  • reighnman - Monday, May 24, 2010 - link

    0002 is back up with a new update tool, hopefully we'll see some more testing :) Reply
  • Golgatha - Wednesday, May 26, 2010 - link

    Check my post. I have a link to the firmware download page as well.

    http://forums.anandtech.com/showthread.php?t=20770...

    Drive is as fast as ever across the entire drive.
    Reply
  • Ol'Bud - Saturday, June 19, 2010 - link

    My C300 was RMA to newegg and they were very supportive and paid it back.

    Then it went on sale after the issues with firmware had been resolved and it was more than a hundred dollars cheaper,
    So I re-ordered.

    Everything is running just fine now.
    Reply

Log in

Don't have an account? Sign up now